登录
注册
node.js 学习社区
安装包的时候报出一下的错误信息

QIJI

2017-07-13 18:11

 npm WARN studyNode@1.0.0 No description
npm WARN studyNode@1.0.0 No repository field.
npm ERR! Darwin 16.6.0
npm ERR! argv "/Users/Sun/.nvm/versions/node/v6.6.0/bin/node" "/Users/Sun/.nvm/versions/node/v6.6.0/bin/npm" "i"
npm ERR! node v6.6.0
npm ERR! npm  v3.10.3
npm ERR! file sh
npm ERR! code ELIFECYCLE
npm ERR! errno ENOENT
npm ERR! syscall spawn

npm ERR! graphicsmagick@0.0.1 preinstall: `node-waf clean || (exit 0); node-waf configure build`
npm ERR! spawn ENOENT
npm ERR!
npm ERR! Failed at the graphicsmagick@0.0.1 preinstall script 'node-waf clean || (exit 0); node-waf configure build'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the graphicsmagick package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node-waf clean || (exit 0); node-waf configure build
npm ERR! You can get information on how to open an issue for this project with:
npm ERR!     npm bugs graphicsmagick
npm ERR! Or if that isn't available, you can get their info via:
npm ERR!     npm owner ls graphicsmagick
npm ERR! There is likely additional logging output above. 

系统环境: MacOS 10.12.5

node版本: 6.11.1

回复 · 0

发表回复

你可以在回复中 @ 其他人