登录
注册
node.js 学习社区
semver

完美

2017-09-07 10:44

项目中var mongoose =require ("mongoose")的时候,

报错 -> ->

cannot find module "semver"

问了很多人了,也查了资料,但是不知道哪的问题,希望大神帮我指点一下.

回复 · 3

  • cannot find module "semver"

    找不到某个包,那就你就安装某个包好了 : npm install semver

    还有类似这种无缘无故的问题,最必杀的解决办法是,删除 node_modules ,重新安装一下npm install

    再不行,卸载node ,安装个新版本node


    1

  • 试过很多次 ,重新安装node,都是免疫伤害.

    我估计删除node_modules,重新npm会有效果吧,试试看!

    谢谢你,美女.

    0

  • C:\Users\HP>npm install -g express

    Unhandled rejection Error: EPERM: operation not permitted, mkdir 'C:\Program Files\nodejs\node_cache\_cacache'


    npm ERR! cb() never called!


    npm ERR! This is an error with npm itself. Please report this error at:

    npm ERR! <https://github.com/npm/npm/issues>

    请问这个报错是什么原因呢?npm install -g express,报错.怎么解决呢?

    0

发表回复

你可以在回复中 @ 其他人